Joomla! 1.5.10 не сумісна з PHP 5.3.x.
Написав    Неділя, 10 лютого 2013, 13:55    PDF Друк e-mail
Розробник

Після оновлення PHP 5.2.х до PHP 5.3.х сайти на Joomla 1.5.10 перестають працювати!
як на фронтенді так і в адмін частині

Warning: Parameter 1 to modMainMenuHelper::buildXML() expected to be a reference
Warning: Parameter 1 to JHTMLGrid::access() expected to be a reference,
Warning: Parameter 1 to JHTMLGrid::checkedOut() expected to be a reference

і тому подібне

 

Причина цьому є те, що Joomla! 1.5.10 не сумісною з PHP 5.3.x. Лише починаючи з Joomla! 1.5.15 добавлено сумісність з PHP 5.3.x. Рішення доволі просте оновіть версію до останньої доступної з http://joomlacode.org/gf/project/joomla/frs/ знайшовши там патч Joomla_1.5.0_to_1.5.ХХ-Stable-Patch_Package.в

ПС. Незабувайте почисти кеш браузера оскільки JavaScript  може бути зміненим.

Останнє оновлення ( Неділя, 10 лютого 2013, 14:45 )
 

Відвідування

mod_vvisit_countermod_vvisit_countermod_vvisit_countermod_vvisit_countermod_vvisit_countermod_vvisit_counter
mod_vvisit_counterСьогодні140
mod_vvisit_counterВчора374
mod_vvisit_counterЗа цей тиждень672
mod_vvisit_counterЗа минулий тиждень1102
mod_vvisit_counterЦього місяця3945
mod_vvisit_counterПопереднього місяця5716
mod_vvisit_counterВсього694659

Кількість користувачів: 3
Ваш IP: 35.175.191.168
,
Сьогодні: жовт. 22, 2019